Erledigt: meine gallery mit safari (bitte testen)

 


scissabob
Gast

09.02.07
10:54 Uhr
ich hab da seit geraumer zeit probleme mit meiner webseitengallery unter safari.

ich habe jetzt versucht, das ganze mit greybox zu öffnen und hoffe, dass es so auch im safari funktioniert.

kann bitte von euch mal jemand gucken? ich habe keinen mac...

hier klicken und im neuesten newsbeitrag „concerts 2007“ anklicken und durch die gallery scrollen ()


danke!
Link zu diesem Beitrag in die Zwischenablage kopieren
Mister Ad
Werbung
Schon mal bei Saturn, DaWanda oder notebooksbilliger.de geguckt? Vielleicht wirst du dort fuendig.

 
Coq
Veteran

09.02.07
11:00 Uhr
funktioniert bei mir nicht. die einzelnen Gallerien werden noch angezeigt. Wenn man dann allerdings eine betrachten wird passiert nix mehr. Unter Firefox läufts einwandfrei...
Link zu diesem Beitrag in die Zwischenablage kopieren
scissabob
Gast

09.02.07
11:01 Uhr
fuck.....
danke fürs testen!

scheiss safari

irgendwie mag der safari keine iframes
auf meinem myspace account läuft das auch aufm safari
Link zu diesem Beitrag in die Zwischenablage kopieren
scissabob
Gast

09.02.07
11:10 Uhr
xp mit ff geht 100%

dann ist ja gut )
Link zu diesem Beitrag in die Zwischenablage kopieren
scissabob
Gast

09.02.07
12:08 Uhr
danke )
Link zu diesem Beitrag in die Zwischenablage kopieren
scissabob
Gast

09.02.07
12:32 Uhr
auch die older concerts und other pics und überhaupt alle????
Link zu diesem Beitrag in die Zwischenablage kopieren
scissabob
Gast

09.02.07
12:43 Uhr
haha....

na dann viel spass dabei )

leider ist bei „other pics“ kein sound dabei...
aber dafür bei den bandpromos wieder...
Link zu diesem Beitrag in die Zwischenablage kopieren
scissabob
Gast

15.06.07
07:23 Uhr
hat jemand schon den neuen safari3 drauf und kann nochmal meine gallery testen, bitte?
aufm pc mit safari3 funktionierts komischerweise....

vielleicht ja jetzt auch aufm mac? )
Link zu diesem Beitrag in die Zwischenablage kopieren
septi
Gast

15.06.07
09:17 Uhr
ja, hab safari3 unter mac drauf und es geht.

e: ehm sound kann ich grad nicht testen, hock in der vorlesung ;-) aber bildwechsel geht fein
Link zu diesem Beitrag in die Zwischenablage kopieren
passij
Veteran

15.06.07
09:21 Uhr
harhar, auch eine methode die browserungleichheiten auszubügeln: abwarten

eek
Link zu diesem Beitrag in die Zwischenablage kopieren
scissabob
Gast

15.06.07
09:29 Uhr
super, vielen dank, septi!!!
wenn die fotos zu sehen sind, geht auch der sound.

@passij: naja, was soll ich machen, wenn der safari2xx probleme hat swf in einem iframe darzustellen...
aber jetzt haben sie es ja endlich geschafft *jubeljubelfreufreu*
Link zu diesem Beitrag in die Zwischenablage kopieren
Naboolean
Gast

15.06.07
10:02 Uhr
Bindest du das SWF direkt in den iframe ein?
Wenn ja, was spricht gegen Einbettung in ein HTML-Dokument?
Link zu diesem Beitrag in die Zwischenablage kopieren
scissabob
Gast

15.06.07
10:29 Uhr
das problem ist, dass meine seite mit php aufgebaut ist und link ein bild ist.
meine gallery soll sich dann über die php-seite legen und auch das bild verdecken, und das geht mit nem iframe ganz gut.

ich hab ja im programmieren nur halbwissen und hab mir mein php gerüst damals aufbauen lassen und hatte damals das problem, dass ich nicht wusste, wie ich das bild links wegbekomme, dann hat mir ein freund ein iframe drübergebastelt.
funktioniert grundsätzlich bei jedem browser, ausser eben safari2xx... aber jetzt gehts ja dann )
Link zu diesem Beitrag in die Zwischenablage kopieren
Naboolean
Gast

15.06.07
10:49 Uhr
Also technisch wär’s kein Problem. ;)
Link zu diesem Beitrag in die Zwischenablage kopieren
scissabob
Gast

15.06.07
11:43 Uhr
was wäre technisch kein problem?
Link zu diesem Beitrag in die Zwischenablage kopieren
Naboolean
Gast

15.06.07
11:57 Uhr
Das SWF in ein HTML-Dokument einzubetten (per <object>/<embed>) und dann das HTML-Dokument in das iframe einzubinden.
So es denn daran liegt, dass Safari Probleme macht, denn das SWF wird bei mir noch korrekt geladen und verschwindet erst, wenn man eine Galerie auswählt.
Link zu diesem Beitrag in die Zwischenablage kopieren
septi
Gast

15.06.07
12:19 Uhr
du kannst per mod-rewrite ueber htaccess die links auf den fotos umwandeln lassen. dann musst du auch kaum was am php-code aendern

sprich aus www.foobar.com/gallery/album1/foto1.jpg wird per mod-rewrite www.foobar.com/?album=1&foto=1 gemacht, was dann zum beispiel von index.php generiert wird.
Link zu diesem Beitrag in die Zwischenablage kopieren
scissabob
Gast

15.06.07
13:28 Uhr
@septi: ehrlich gesagt, versteh ich kein wort.... )

@naboolean: meinst du, es würde funktionieren, wenn ich das über den html-„umweg“ mache?

ich weiss auch ehrlich gesagt gar nicht, ob sich das überhaupt noch lohnt, da es ja mit safari3 funktioniert...
Link zu diesem Beitrag in die Zwischenablage kopieren
Naboolean
Gast

15.06.07
14:24 Uhr
Ich verstehe auch nicht, auf was septi hinaus will. ;)

So geht es jedenfalls bei mir im Safari: http://johannes.emerich.de/tmp/scissa.html
Da sind jetzt Scrollbalken, man müsste die Größenangaben halt entsprechend anpassen.

Wobei ich nicht ganz kapiere, für was der iframe überhaupt gut sein soll.
Link zu diesem Beitrag in die Zwischenablage kopieren
scissabob
Gast

16.06.07
15:19 Uhr
und so kannst du die bilder auch auf safari2xx sehen??

hmmm, wenn du mir sagst, wie du das gemacht hast, ändere ichs vielleicht noch... )
Link zu diesem Beitrag in die Zwischenablage kopieren
Naboolean
Gast

16.06.07
15:50 Uhr
Ja.

  1. <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
  2.  
  3. <html lang="en">
  4. <head>
  5. <meta http-equiv="Content-Type" content="text/html; charset=utf-8">
  6. <title>scissabobs Bilder</title>
  7. </head>
  8.  
  9. <?php
  10. // Namen der SWF-Datei aus URL-Parameter holen
  11.  
  12. $fname = $_GET['gallery'];
  13.  
  14. ?>
  15.  
  16. <body>
  17. <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,0,0" height="65" width="580" align="right">
  18. <param name="movie" value="ssp_director/<?php echo $fname; ?>.swf">
  19. <param name="quality" value="best">
  20. <param name="play" value="true">
  21. <embed align="right" height="430" pluginspage="http://www.macromedia.com/go/getflashplayer" src="ssp_director/<?php echo $fname; ?>.swf" type="application/x-shockwave-flash" width="800" quality="best" play="true">
  22.  
  23. </object>
  24. </body>
  25. </html>
Quelltext in Zwischenablage kopieren

Wenn du das als iframe.php speicherst und im iframe als src jeweils iframe.php?gallery=<Name der SWF-Datei ohne .swf> angibst, sollte es gehen.
Beziehungsweise muss noch index.php entsprechend angepasst werden. Kann ich schnell machen, wenn du sie postest.
Link zu diesem Beitrag in die Zwischenablage kopieren
scissabob
Gast

16.06.07
21:03 Uhr
vielen dank, ich schau mir das morgen mal an!! )
Link zu diesem Beitrag in die Zwischenablage kopieren
Alex
Gast

17.06.07
16:01 Uhr
# <html lang=“en“>
# <head>
# <meta http-equiv=“Content-Type“ content=“text/html; charset=utf-8“>
# <title>scissabobs Bilder</title>
# </head>

Lang=“en“ und der title ein Widerspruch in sich ...
Link zu diesem Beitrag in die Zwischenablage kopieren
Naboolean
Gast

17.06.07
17:38 Uhr
Nicht in sich. Das ist halt das Standard-Markup, das TextMate erstellt.
Link zu diesem Beitrag in die Zwischenablage kopieren
 
#